Queue Tree & Mangle
Queue Tree dan Mangel
Queue tree adalah fitur yang terdapat dalam mikrotik yang igunakan untuk mengatur jumlah bandwidth. Berfungsi untuk mengimplementasikan fungsi yang lebih komplex dalam limit bandwidth.
Mangle adalah sebuah fitur mikrotik yang digunakan untuk menandai sebuah paket, sehingga paket tersebut memiliki sebuah identitas khusus di router.
Berikut adalah scriptnya :
/ip firewall mangle add chain=prerouting src-address=200.100.10.2 action=mark-connection passthrough=yes new-connection-mark=warnet-pc1 disable=no comment=warnet;
/ip firewall mangle add chain=prerouting connection-mark=warnet-pc1 action=mark-packet passthrough=yes new-packet-mark=warnet-pc1 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.10.3 action=mark-connection passthrough=yes new-connection-mark=warnet-pc2 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=warnet-pc2 action=mark-packet passthrough=yes new-packet-mark=warnet-pc2 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.10.4 action=mark-connection passthrough=yes new-connection-mark=warnet-pc3 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=warnet-pc3 action=mark-packet passthrough=yes new-packet-mark=warnet-pc3 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.10.5 action=mark-connection passthrough=yes new-connection-mark=warnet-pc4 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=warnet-pc4 action=mark-packet passthrough=yes new-packet-mark=warnet-pc4 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.10.6 action=mark-connection passthrough=yes new-connection-mark=warnet-pc5 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=warnet-pc5 action=mark-packet passthrough=yes new-packet-mark=warnet-pc5 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.11.2 action=mark-connection passthrough=yes new-connection-mark=kantor-pc1 disable=no comment=kantor;
/ip firewall mangle add chain=prerouting connection-mark=kantor-pc1 action=mark-packet passthrough=yes new-packet-mark=kantor-pc1 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.11.3 action=mark-connection passthrough=yes new-connection-mark=kantor-pc2 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=kantor-pc2 action=mark-packet passthrough=yes new-packet-mark=kantor-pc2 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.11.4 action=mark-connection passthrough=yes new-connection-mark=kantor-pc3 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=kantor-pc3 action=mark-packet passthrough=yes new-packet-mark=kantor-pc3 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.11.5 action=mark-connection passthrough=yes new-connection-mark=kantor-pc4 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=kantor-pc4 action=mark-packet passthrough=yes new-packet-mark=kantor-pc4 disable=no;
/ip firewall mangle add chain=prerouting src-address=200.100.11.6 action=mark-connection passthrough=yes new-connection-mark=kantor-pc5 disable=no;
/ip firewall mangle add chain=prerouting connection-mark=kantor-pc5 action=mark-packet passthrough=yes new-packet-mark=kantor-pc5 disable=no;
/queue tree add name=warnet-up max-limit=128k parent=wlan1 priority=8;
/queue tree add name=warnet-down max-limit=128k parent=ether1 priority=8;
/queue tree add name=kantor-up max-limit=150k parent=wlan1 priority=8;
/queue tree add name=kantor-down max-limit=150k parent=ether2 priority=8;
/queue tree add name=warnet-up-pc1 max-limit=128k limit-at=64k packet-mark=warnet-pc1 parent=warnet-up;
/queue tree add name=warnet-down-pc1 max-limit=128k limit-at=64k packet-mark=warnet-pc1 parent=warnet-down;
/queue tree add name=warnet-up-pc2 max-limit=128k limit-at=64k packet-mark=warnet-pc2 parent=warnet-up;
/queue tree add name=warnet-down-pc2 max-limit=128k limit-at=64k packet-mark=warnet-pc2 parent=warnet-down;
/queue tree add name=warnet-up-pc3 max-limit=128k limit-at=64k packet-mark=warnet-pc3 parent=warnet-up;
/queue tree add name=warnet-down-pc3 max-limit=128k limit-at=64k packet-mark=warnet-pc3 parent=warnet-down;
/queue tree add name=warnet-up-pc4 max-limit=128k limit-at=64k packet-mark=warnet-pc4 parent=warnet-up;
/queue tree add name=warnet-down-pc4 max-limit=128k limit-at=64k packet-mark=warnet-pc4 parent=warnet-down;
/queue tree add name=warnet-up-pc5 max-limit=128k limit-at=64k packet-mark=warnet-pc5 parent=warnet-up;
/queue tree add name=warnet-down-pc5 max-limit=128k limit-at=64k packet-mark=warnet-pc5 parent=warnet-down;
/queue tree add name=kantor-up-pc1 max-limit=150k limit-at=75k packet-mark=kantor-pc1 parent=kantor-up;
/queue tree add name=kantor-down-pc1 max-limit=150k limit-at=75k packet-mark=kantor-pc1 parent=kantor-down;
/queue tree add name=kantor-up-pc2 max-limit=150k limit-at=75k packet-mark=kantor-pc2 parent=kantor-up;
/queue tree add name=kantor-down-pc2 max-limit=150k limit-at=75k packet-mark=kantor-pc2 parent=kantor-down;
/queue tree add name=kantor-up-pc3 max-limit=150k limit-at=75k packet-mark=kantor-pc3 parent=kantor-up;
/queue tree add name=kantor-down-pc3 max-limit=150k limit-at=75k packet-mark=kantor-pc3 parent=kantor-down;
/queue tree add name=kantor-up-pc4 max-limit=150k limit-at=75k packet-mark=kantor-pc4 parent=kantor-up;
/queue tree add name=kantor-down-pc4 max-limit=150k limit-at=75k packet-mark=kantor-pc4 parent=kantor-down;
/queue tree add name=kantor-up-pc5 max-limit=150k limit-at=75k packet-mark=kantor-pc5 parent=kantor-up;
/queue tree add name=kantor-down-pc5 max-limit=150k limit-at=75k packet-mark=kantor-pc5 parent=kantor-down;
Pengujian
Komentar
Posting Komentar